Bug #65477

ajax requests not working anymore

Added by Nicole Cordes over 5 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Backend API
Target version:
Start date:
2015-03-03
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Due to patch https://review.typo3.org/#/c/37409/ the global ajaxID isn't set anymore. This breaks ajax requests as no id is given anymore.

Associated revisions

Revision 633e02b2 (diff)
Added by Nicole Cordes over 5 years ago

[BUGFIX] Reset global ajaxID for ajax requests

Due to patch https://review.typo3.org/#/c/37409/ the global ajaxID
isn't set anymore. This variable is needed by several ajax requests and
expected to be set in global context. This patch sets the given ajaxID
globally.

Releases: master
Resolves: #65477
Change-Id: Id06d9b6a4d7bf41061e917ed6049a3dfefbf32f0
Reviewed-on: http://review.typo3.org/37493
Reviewed-by: Stephan Großberndt <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37493

#2 Updated by Nicole Cordes over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Riccardo De Contardi almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF