Bug #65624

$GLOBALS['TYPO3_CONF_VARS']['SYS']['binSetup'] doesn't respect new lines

Added by Nicole Cordes over 5 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend API
Target version:
Start date:
2015-03-09
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If you separate the list of programs in ['SYS']['binSetup'] by new line, the binaries aren't found due to parsing issues.

Associated revisions

Revision f04fac9f (diff)
Added by Nicole Cordes over 5 years ago

[BUGFIX] Respect newlines in ['SYS']['binSetup']

If you separate the list of programs by new line (as suggested in the
Install Tool description), the programs aren't found.
The problem is that the newline is saved as string component by
the Install Tool. Therefore the new line separator (LF) has to
be replaced before splitting the value.

Releases: master, 6.2
Resolves: #65624
Change-Id: I39d8634265bf69d58ad4af3fd2eac913a14a3ef5
Reviewed-on: http://review.typo3.org/37672
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

Revision 485668b1 (diff)
Added by Nicole Cordes over 5 years ago

[BUGFIX] Respect newlines in ['SYS']['binSetup']

If you separate the list of programs by new line (as suggested in the
Install Tool description), the programs aren't found.
The problem is that the newline is saved as string component by
the Install Tool. Therefore the new line separator (LF) has to
be replaced before splitting the value.

Releases: master, 6.2
Resolves: #65624
Change-Id: I39d8634265bf69d58ad4af3fd2eac913a14a3ef5
Reviewed-on: http://review.typo3.org/37682
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

History

#1 Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37672

#2 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37672

#3 Updated by Gerrit Code Review over 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37672

#4 Updated by Gerrit Code Review over 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37672

#5 Updated by Gerrit Code Review over 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37682

#6 Updated by Nicole Cordes over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Riccardo De Contardi about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF