Bug #65828

Extension manager can not handle composer requirements

Added by Alexander Stehlik about 5 years ago. Updated about 5 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2015-03-18
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Currently the Extension manager will fail to calculate dependencies correctly, when a require statement with a composer compatible package name is used:

E.g. when I put

"require": {
    "typo3-ter/news": "*" 
},

in the composer.json of an extension that is based the news extension, the Extension manager will throw an Exception, because he does not know the "typo3-ter/news" extension.

It is also not possible to just use

"require": {
    "news": "*" 
},

because the composer does not know about this extension and will fail to build the correct requirements (see also #63605).

A possible solution would be to cut off the typo3-ter prefix when the requirements are calculated.

History

#1 Updated by Nicole Cordes about 5 years ago

  • Description updated (diff)
  • Status changed from New to Rejected

The extension manager will not support any composer packages and therefore doesn't resolves any package names. If you want to use composer please use composer.json and composer install, otherwise just use the proper extension key in the requirement.

#2 Updated by Alexander Stehlik about 5 years ago

I'm not sure, if the problem was understand correctly. I do not expect the Extension Manager to install dependencies depending on composer.json files.

But I expect it not to crash, when I install extensions using composer. Either it should use the configuration of the composer.json files correctly or it should not read them at all and rely on ext_emconf.php files only. Then the problem would also be solved.

Reading composer.json files and not supporting the format correctly is a bug and needs to be fixed. The one way or the other.

Ping me on slack if further explanations is needed :)

Also available in: Atom PDF