Bug #65835

Simple types int/bool/double cause Exceptions when beeing mapped

Added by Nils Blattner over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extbase
Target version:
Start date:
2015-03-19
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hi there

There is an issue when using aliased simple (target) types (int/bool/double) in PHDoc. During mapping it correctly identifies them as integer/boolean/float but fails to map them, because there is no type handling definition for int etc.

This can be remedied by calling \TYPO3\CMS\Extbase\Utility\TypeHandlingUtility::normalizeType() in the PropertyMapper (see attached patch).

Found in 6.2.9, still relevant in 6.2.11.

Kind regards
Nils

PropertyMapper.php.diff View (845 Bytes) Nils Blattner, 2015-03-19 08:17

History

#1 Updated by Wouter Wolters about 4 years ago

  • Status changed from New to Closed

Hi, meanwhile this has been resolved with https://forge.typo3.org/issues/67044
Is included in latest 6.2 release.

Also available in: Atom PDF