Project

General

Profile

Actions

Bug #66093

closed

Improper file relations to content element in draft workspace

Added by Leslaw Pazdzior almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Workspaces
Target version:
Start date:
2015-03-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

When I added a picture file into content element (type images or text+images) in draft workspace - it doesn't appear in draft/live front-end preview. Also when I publish page.

When I add second picture to this element in draft space - all pictures shows on live front-end. Actually picture that is already in live and draft workspace is doubled in preview, and draft preview is still empty.


Situation however looks proper in back-end (in both list and page module).

I noticed that reason is that all relations in sys_file_references are connected to live version of the element, not to it's shadow. So when I corrected manually uid_foreign to proper one - situation was fixed on preview! (live id of tt_content record is 254011, shadow is 254013).

References in db before:

And after fixing relation:

It was tested on 6.2.10. It's similar on 6.2.11 and newest 6.2.12-dev, however I wasn't able to test it fully, since I wasn't able to reedit content element in draft space after saving :(.

I have a big customer that uses workspaces massively so upgrade to 6.2 from 6.1 is now problematic.


Files

scrn_002.png (143 KB) scrn_002.png Leslaw Pazdzior, 2015-03-27 13:33
scrn_004.png (53.5 KB) scrn_004.png Leslaw Pazdzior, 2015-03-27 13:33
scrn_003.png (176 KB) scrn_003.png Leslaw Pazdzior, 2015-03-27 13:33
scrn_005.png (207 KB) scrn_005.png Leslaw Pazdzior, 2015-03-27 13:33
scrn_006.png (75.3 KB) scrn_006.png Leslaw Pazdzior, 2015-03-27 13:33
scrn_007.png (47.5 KB) scrn_007.png Leslaw Pazdzior, 2015-03-27 13:33
Actions #1

Updated by Leslaw Pazdzior almost 9 years ago

  • Assignee set to Leslaw Pazdzior

I'm sorry, i tested it again - it was caused by hook in media extension (version 3.3.0). It works properly without it! So you can delete/close this issue.

Actions #2

Updated by Leslaw Pazdzior almost 9 years ago

  • Assignee deleted (Leslaw Pazdzior)
Actions #3

Updated by Riccardo De Contardi almost 9 years ago

  • Status changed from New to Closed

closed as per request of the reporter

Actions

Also available in: Atom PDF