Bug #66185

File-Links not open in a new window

Added by Boris Makarov about 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2015-03-31
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I have a "Content Element" from Type: "File Links"

I add some files to the site (pdf,jpg,png) and i set the option "Target: _blank" (for open in a new window)

And here is the problem.... in the frontend any files open in the same windows, doesn't in a new window

#1

Updated by Markus Klein about 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (next-patchlevel)

I can't reproduce the problem.

Which TYPO3 version are you using exactly?

Which CSS styled content static template are you using?

#2

Updated by Boris Makarov about 6 years ago

TYPO3 6.2.11

I think this a self made static template (i don't write it).

This is a intranet homepage from my company and i migrate it from TYPO3 4.5 to 6.2.

Here is the source code from a link under TYPO3 4.5 (it work):

<ul class="csc-uploads csc-uploads-0">

    <li class="li-odd li-first csc-uploads-element csc-uploads-element-pdf">
        <a target="_blank" href="uploads/media/Leitbild-AV-V1.0_02.pdf">
            <span class="csc-uploads-fileName"></span>
        </a>
        <span class="csc-uploads-description"></span>
    </li>

And this is after migration to TYPO3 6.2 (never work):

<ul class="csc-uploads csc-uploads-0">

    <li class="li-odd li-first csc-uploads-element csc-uploads-element-pdf">
        <span class="csc-uploads-fileName">
            <a href="fileadmin/_migrated/content_uploads/Leitbild-AV-V1.0_02.pdf"></a>
        </span>
        <span class="csc-uploads-description"></span>
    </li>

We can see is never target="_blank" in the code but don't know why...

#3

Updated by Markus Klein about 6 years ago

  • Status changed from Needs Feedback to Closed

Please use the forum to get support for your TypoScript configuration. You have more helping hands there.

Since we can't reproduce the problem, I close this issue.

Also available in: Atom PDF