Bug #66239

Link to External URL not working in translation

Added by Wolfgang Hamster over 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2015-04-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

if default page is type "Standard" and the translated page is type "Link to External URL" the redirect isn't working - only if the default page is also type "Link to External URL"

Can anyone help me?

#1

Updated by Riccardo De Contardi over 6 years ago

I tested with both 6.2.14 and 7.4-dev:

my setup:

1) two languages, italian (Default); english (L=1)
2) TS Setup:

config.linkVars = L
config.uniqueLinkVars = 1
config.sys_language_overlay = content_fallback
config.language = it
config.locale_all = it_IT
config.htmlTag_langKey = it-IT
config.sys_language_uid = 0
[globalVar = GP:L = 1]
config.language = en
config.locale_all = en_EN
config.htmlTag_langKey = en-EN
config.sys_language_uid = 1
[global]

3) create a new page, pagetitle: TEST; type standard
3.1) translate to english, pagetitle: TEST-ENG; edit properties > set as external url (http://www.typo3.org)

RESULTS:
A) TYPO3 6.2.14: the bug is still present
B) TYPO3 7.4-DEV: the bug is not present

#2

Updated by Guido Jansen over 5 years ago

You have to add 'doktype' to the value


    ['FE']['pageOverlayFields']


In LocalConfiguration.php

#3

Updated by Riccardo De Contardi over 5 years ago

  • Status changed from New to Closed

the solution pointed out on comment #2 is the right way to go (doktype has been added to the list [FE][pageOverlayFields] from version 7.x and above); applying it your problem will be solved.
You can use Install Tool to add the field to [FE][pageOverlayFields].

I therefore close this issue because such an easy fix is not planned to be released for version 6.2.x.

If you think this is the wrong decision, then let us know (on Slack for example - https://typo3.slack.com/ ) or open a new ticket and add a relation to this ticket number. Thank you

Also available in: Atom PDF