Bug #66424

fe group limit

Added by Stefa No almost 7 years ago. Updated almost 7 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-04-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello, with Typo3 <= 4.5.x and <= 6.2.x,
user groups are handled as a comma-separated list
of ids inside a string field:

fe_users.usergroup = tinytext (255 chars)

This limit is a problem in an environment using a lot of groups,
(like when you use extensions for ldap integration).

I think it's a delicated question: IF you will
plan to change the way to map user/groups,
I hope there will be some migration tool
(sql/php/bash script, wizard through BE,...)
or backward compatibility... or maybe just
a way (setting?) to customize the field (from tinytext
to text, etc.) without fear that in the next
upgrade the install tool db check could reset
the type to tinytext: but yes, clear, if it's
a rare case, as a workaround we could apply
a sql ALTER, and then it could be
site's admin to that have to be careful
during upgrades...

Thanks for your attention and patience,
Bye

#1

Updated by Christian Kuhn almost 7 years ago

Hello Stefa No.

The core setup strives to come around with sane defaults regarding the size of DB fields. For 99,9% of the usual instances, tinytext is more than enough since most TYPO3 instances just have a couple of groups applied to a fe user.

So, the core will probably not change the size of this field.

Supported solution: Go to your project extension - you have one, right? It is the one that contains all your html, typoScript and other custom stuff. Overwrite the size of this field in its ext_tables.sql. This will work since your project extension is loaded after other casual extensions (sidenote: load order can be influenced by setting dependencies to other extensions). The database analyzer will then understand this change and compares the db size of the DB field with your defined value.

CREATE TABLE fe_users (
  usergroup text
);

#2

Updated by Christian Kuhn almost 7 years ago

  • Status changed from New to Needs Feedback
#3

Updated by Christian Kuhn almost 7 years ago

hope this helps. could you please try this and tell us if you're satisfied with this solution?

#4

Updated by Christian Kuhn almost 7 years ago

  • Status changed from Needs Feedback to Rejected

I'll close this issue now as rejected since the default sice fits most needs and overwriting the size of single fields if needed is a supported standard scenario of the system. Feel free to re-open if you think we missed something.

Also available in: Atom PDF