Bug #69063

Admin user can't filter page tree

Added by Nicole Cordes about 5 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2015-08-14
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

An admin user can't filter page tree if

a) a group is assigned to the user
b) the group has a mount point
c) the page isn't within the mountpoint

To test this with the introduction package, please make following chances to your admin user:

a) assign Simple editors group
b) search a page outside the mountpoint (e.g. 12 -> About / History)

-> nothing is found but page should be found as the admin has to right to view everything


Related issues

Duplicates TYPO3 Core - Bug #41802: PageTree-filter not working for Admins if admin has additional DB mounts Closed 2012-10-09

Associated revisions

Revision 5fad1445 (diff)
Added by Nicole Cordes about 5 years ago

[BUGFIX] Enable page tree filter for admin with mountpoints

The patch prevents the mountpoint processing during page tree filtering
for admin users. This is necessary because admin users aren't limited
to the mountpoints. Otherwise sites outside the mountpoints aren't
found anymore.

Resolves: #69063
Releases: master, 6.2
Change-Id: Ie55dcc3b05463deaf57ba42c91e229225176be8a
Reviewed-on: http://review.typo3.org/42617
Reviewed-by: Helmut Hummel <>
Reviewed-by: Alexander Opitz <>
Tested-by: Alexander Opitz <>
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>

Revision 46a6bb89 (diff)
Added by Nicole Cordes about 5 years ago

[BUGFIX] Enable page tree filter for admin with mountpoints

The patch prevents the mountpoint processing during page tree filtering
for admin users. This is necessary because admin users aren't limited
to the mountpoints. Otherwise sites outside the mountpoints aren't
found anymore.

Resolves: #69063
Releases: master, 6.2
Change-Id: Ie55dcc3b05463deaf57ba42c91e229225176be8a
Reviewed-on: http://review.typo3.org/43018
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>

History

#1 Updated by Gerrit Code Review about 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42617

#2 Updated by Gerrit Code Review about 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42617

#3 Updated by Gerrit Code Review about 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42617

#4 Updated by Gerrit Code Review about 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42617

#5 Updated by Gerrit Code Review about 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43018

#6 Updated by Nicole Cordes about 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Riccardo De Contardi almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF