Project

General

Profile

Actions

Bug #69247

closed

Epic #68397: Make TYPO3 work with MySQL strict mode

Inserting records fails when the model has a incompatible default value

Added by Morton Jonuschat almost 9 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Category:
Extbase
Target version:
Start date:
2015-08-21
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Inserting a new record through an extbase repository fails if the model and the database schema have incompatible defaults.

Example:

If the model has a property `title` without any default value assigned (so its NULL for PHP) and the database schema has the column defined as `title varchar(255) DEFAULT '' NOT NULL` extbase tries to insert an explicit NULL into the database.

This is due to the new default value determination insertObject().


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #69084: Adding Objects with NOT NULL columns is brokenClosedMorton Jonuschat2015-08-15

Actions
Actions #1

Updated by Morton Jonuschat almost 9 years ago

  • Status changed from New to In Progress
Actions #2

Updated by Gerrit Code Review almost 9 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42821

Actions #3

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42821

Actions #4

Updated by Morton Jonuschat over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #5

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF