Bug #69926

New FormEngine uses already extracted row in calls to USER functions, must use original row

Added by Claus Due about 5 years ago. Updated about 5 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-09-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Like the topic says: currently every USER function registered to render a TCA or other type of form field will receive an extracted row where, among other things, CType is an array (!).

Although this indicates a possibly much worse issue, a workaround is to re-load the original record when calling a USER function (since the original, un-extracted record no longer exists, but the table and UID both do).


Related issues

Related to TYPO3 Core - Bug #70132: Document FormEngine user + userfunc is breakingClosed2015-09-27

Actions
#1

Updated by Gerrit Code Review about 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43408

#2

Updated by Gerrit Code Review about 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43408

#3

Updated by Claus Due about 5 years ago

  • Status changed from Under Review to Rejected

Also available in: Atom PDF