Bug #70427

2 requests in itemsProcFunc-Hook in Flexform with renderMode tree

Added by Mathias Bruckmoser about 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-10-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.6
Tags:
6.2.15
Complexity:
Is Regression:
No
Sprint Focus:

Description

- In current TYPO3 Version 6.2.15 this Error only with render mode tree arcurs.
- So mysteriously the second request overwrite the items from first in $config['items'] array and a unknown array_key_exists(0, $config['row']) (screen)

This is my part in a Plugin-flexform:
-------------------------------------
<settings.limits.category>
<TCEforms>
<label>my categories</label>
<config>
<type>select</type>
<itemsProcFunc>Me\FooExt\TCA\SysCategoryList->extendedItemList</itemsProcFunc>
<foreign_table>sys_category</foreign_table>
<minitems>0</minitems>
<maxitems>1</maxitems>
<renderMode>tree</renderMode>
<treeConfig>
<parentField>parent</parentField>
<appearance>
<nonSelectableLevels>0,1</nonSelectableLevels>
<expandAll>1</expandAll>
<showHeader>1</showHeader>
<maxLevels>10</maxLevels>
<width>520</width>
</appearance>
</treeConfig>
</config>
</TCEforms>
</settings.limits.category>


Files

flexform_itemprocbug.jpg (117 KB) flexform_itemprocbug.jpg Mathias Bruckmoser, 2015-10-06 11:38
#1

Updated by Nicole Cordes about 6 years ago

  • Status changed from New to Accepted
  • Assignee set to Nicole Cordes

Will investigate here

#2

Updated by Nicole Cordes about 6 years ago

  • Status changed from Accepted to Needs Feedback

I went back to 6.2.10 and the itemsProcFunc is called twice there as well. Maybe there is some other issue with the script (now)?

#3

Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Nicole Cordes)

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

#4

Updated by Mathias Bruckmoser over 5 years ago

Because of massive changes in TCA and BE in TYPO3 7.6.x this bug seems be solved it self.

Also available in: Atom PDF