Bug #70527

TYPO3 Fluid - exclamation mark on wrong position

Added by Christian Hünniger over 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Fluid
Target version:
-
Start date:
2015-10-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

I've created the following flux backend settings

<f:section name="Configuration">
    <flux:form id="contentTextImage" options="{group: 'Content'}">
        <flux:form.option name="group" value="Content" />

        <flux:form.sheet name="optionsSheet" label="{f:translate(key: 'label.options')}">
            <flux:field.input name="headline" label="{f:translate(key: 'label.headline')}" />
            <flux:field.input name="subline" label="{f:translate(key: 'label.subline')}" />
            <flux:field.select name="headlineLvl" items="{0: {0: 'H3', 1: 'h3'}, 1: {0: 'H2', 1: 'h2'}}" default="h2" label="{f:translate(key: 'label.headlineLvl')}" />
            <flux:field.text name="text" enableRichText="1" label="{f:translate(key: 'label.text')}" />
            <flux:field.file name="image" maxItems="1" minItems="1" label="{f:translate(key: 'label.textImage')}" showThumbnails="true" allowed="jpg, png" />
            <flux:field.select name="imageAlign" label="{f:translate(key: 'label.imageAlign')}" items="{
                0: {0: '{f:translate(key: \'label.imageLeft\')}', 1: 'image-left'},
                1: {0: '{f:translate(key: \'label.imageRight\')}', 1: 'image-right'}
            }" />
        </flux:form.sheet>
    </flux:form>
</f:section>

You can see that the file field has minItems 1 so this is required but the yellow excalation mark is shown on the wrong position in the backend (see attached screenshot)

Some specs
- TYPO3 6.2.15


Files

Screen Shot 2015-10-09 at 10.46.12.png (64.9 KB) Screen Shot 2015-10-09 at 10.46.12.png Christian Hünniger, 2015-10-09 10:48
#1

Updated by Benni Mack over 6 years ago

  • Status changed from New to Resolved

Hey Christian,

we fixed this, but due to the major refactoring of JavaScrip in the backend, this was only doable for TYPO3 v7, so it would be great if you'd update :)

#2

Updated by Christian Hünniger over 6 years ago

Hi Benni

THNQ for your fast answer :) . I will update if the LTS version is released.

You can close the ticket.

#3

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF