Bug #71296

Backend unusable if storage driver is not available

Added by Nicole Cordes over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2015-11-03
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

If I have a storage which relies on a not-existing driver (because I deactivated the extension providing that driver) the backend isn't usable on multiple places anymore.

Associated revisions

Revision 9f131622 (diff)
Added by Nicole Cordes over 4 years ago

[BUGFIX] Catch some FAL exceptions for missing driver

If a driver of a storage isn't available anymore (e.g. because an
extension was deactivated), an exception is thrown and the backend
stops working on multiple sites.

This patch catches the InvalidArgumentException which is thrown by the
DriverRegistry and ensures a proper working mode. The exception is
caught when:

- editing a record with inline record to a file of that storage
- editing a record with image manipulation of a file of that storage
- opening the element browser where the last folder was within that storage

Resolves: #71296
Releases: master
Change-Id: Ide83d411ab6c0e1850ff9cb9eec894753e73727f
Reviewed-on: https://review.typo3.org/44523
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>
Reviewed-by: Alexander Opitz <>
Tested-by: Alexander Opitz <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44523

#2 Updated by Nicole Cordes over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF