Bug #71603

Field "Record Storage Page" is missing exclude flag

Added by Chris topher over 6 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2015-11-16
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If a content element makes use of the field "Record Storage Page" (e.g. the CE "Plugin" does that), then this field incorrectly is shown always and currently cannot be excluded.

That way the field is also shown to users, who actually should not have access to it.

This bug can be fixed by adding the missing "exclude" => 1, to the definition of that field (tt_content.pages) in typo3\sysext\frontend\Configuration\TCA\tt_content.php, around line 689 where it defines 'pages' => ...:

        'pages' => array(
            'exclude' => 1,
            'label' => 'LLL:EXT:lang/locallang_general.xlf:LGL.startingpoint',
            ...
#1

Updated by Gianluigi Martino over 6 years ago

i cannot reproduce this, can you please test again?

#2

Updated by Chris topher over 6 years ago

The problem exists: When you edit a Backend user's exclude fields, then the field "Record Storage Page" (tt_content.pages) does not get listed in the list of exclude fields making it impossible to hide that field.

It works after adding the missing exclude flag as I showed above in the three lines of code.

#3

Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44912

#4

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44912

#5

Updated by Gianluigi Martino over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF