Bug #71762

Referencing not working for settings

Added by Pascal Dürsteler almost 6 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
TypoScript
Target version:
-
Start date:
2015-11-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Referencing TypoScript through the referencing operator (=<) is not working as expected, when you reference plugin settings to backend settings to have the same set of data for the backend module.

Example:

plugin.tx_ext.settings =< module.tx_ext.settings

Does not resolve the current settings, but wrong ones, when fetched via

$configurationManager->getConfiguration(ConfigurationManagerInterface::CONFIGURATION_TYPE_FULL_TYPOSCRIPT);

IMHO this is quite a blocker for extension development when functionality in FE plugins and BE modules is expected to be the same because it is based on settings. Thus, assigning "must have".


Related issues

Related to TYPO3 Core - Feature #63894: Evaluate reference handling on TS parser levelNew2014-12-14

Actions

Also available in: Atom PDF