Bug #72094

Default focus on alerts / modal boxes

Added by Pascal Dürsteler almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2015-12-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Currently, when e.g. deleting records, the cancel button is first, and has focus on it. If I want to confirm the dialogue with enter, it is cancelled (which is also done with "esc").

Personally, I'd expect to press "enter" to confirm, as I was able before.


Related issues

Related to TYPO3 Core - Bug #72099: The active button in the backend dialogs should also have the highlight colorRejected2015-12-08

Actions
#1

Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45175

#2

Updated by Andreas Fernandez almost 6 years ago

  • Status changed from Under Review to New

Patch was abandoned.

#3

Updated by Frans Saris almost 6 years ago

As mentioned in review:

"The current behavior is intended. We put the default action on the abort button as the positive action is destructive in most cases."

Tabbing (hitting TAB key) between the buttons works perfectly. That way you can easily focus the OK button and press enter.

I think this issue can be closed.

#4

Updated by Frans Saris almost 6 years ago

  • Status changed from New to Needs Feedback
#5

Updated by Gianluigi Martino almost 6 years ago

  • Status changed from Needs Feedback to Closed

I abandoned the patch for the reason mentioned, so i think we can close

Also available in: Atom PDF