Bug #72591

Duplicate id for content element "Text & Media"

Added by Florian Rival almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Fluid Styled Content
Target version:
-
Start date:
2016-01-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

If you create a content element of type "Text & Media", the id is duplicated.

<div id="c18" class="csc-default">
<div id="c18">
....
</div>
</div>

The reason is because the id is in this file :
typo3/sysext/fluid_styled_content/Resources/Private/Templates/Content/Textmedia.html

And is also in the Typoscript :

tt_content.stdWrap.innerWrap.cObject.default.10.cObject.default.value = <div id="c{field:uid}"

I think it could be suppressed from this file : "Textmedia.html"

#1

Updated by Wouter Wolters almost 5 years ago

  • Status changed from New to Closed
  • Assignee deleted (Benni Mack)

Hi Florian,

tt_content.stdWrap.innerWrap.cObject.default.10.cObject.default.value = <div id="c{field:uid}" is set in the TypoScript of css_styled_content.
When working with fluid_styled_content you need to make sure you don't have the Static TypoScript loaded from css_styled_content.

fluid_styled_content doesn't set the innerWrap in TypoScript.

Also available in: Atom PDF