Bug #73006

Failing Unit Tests on Windows system

Added by Nicole Cordes over 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2016-01-29
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

1) TYPO3\CMS\Core\Tests\Unit\Cache\Backend\FileBackendTest::setCacheDirectoryAllowsRelativePathWithoutTrailingSlash
Failed asserting that two strings are equal.
--- Expected
++ Actual
@ @
-'D:\Server\typo3\master.typo3.local/tmp/foo/test/'
'D:/Server/typo3/master.typo3.local/tmp/foo/test/'

D:\Version Control\Git\TYPO3\TYPO3.CMS\master\typo3\sysext\core\Tests\Unit\Cache\Backend\FileBackendTest.php:88
D:\Version Control\Git\TYPO3\TYPO3.CMS\master\vendor\phpunit\phpunit\phpunit:47

2) TYPO3\CMS\Core\Tests\Unit\Cache\Backend\FileBackendTest::setCacheDirectoryAllowsRelativePathWithTrailingSlash
Failed asserting that two strings are equal.
--- Expected
++ Actual
@ @
-'D:\Server\typo3\master.typo3.local/tmp/foo/test/'
'D:/Server/typo3/master.typo3.local/tmp/foo/test/'

D:\Version Control\Git\TYPO3\TYPO3.CMS\master\typo3\sysext\core\Tests\Unit\Cache\Backend\FileBackendTest.php:101
D:\Version Control\Git\TYPO3\TYPO3.CMS\master\vendor\phpunit\phpunit\phpunit:47

3) TYPO3\CMS\Core\Tests\Unit\Cache\Backend\FileBackendTest::setCacheDirectoryAllowsRelativeDottedPathWithoutTrailingSlash
Failed asserting that two strings are equal.
--- Expected
++ Actual
@ @
-'D:\Server\typo3\master.typo3.local/../tmp/foo/test/'
'D:/Server/typo3/master.typo3.local/../tmp/foo/test/'

D:\Version Control\Git\TYPO3\TYPO3.CMS\master\typo3\sysext\core\Tests\Unit\Cache\Backend\FileBackendTest.php:114
D:\Version Control\Git\TYPO3\TYPO3.CMS\master\vendor\phpunit\phpunit\phpunit:47

4) TYPO3\CMS\Core\Tests\Unit\Cache\Backend\FileBackendTest::setCacheDirectoryAllowsRelativeDottedPathWithTrailingSlash
Failed asserting that two strings are equal.
--- Expected
++ Actual
@ @
-'D:\Server\typo3\master.typo3.local/../tmp/foo/test/'
'D:/Server/typo3/master.typo3.local/../tmp/foo/test/'

D:\Version Control\Git\TYPO3\TYPO3.CMS\master\typo3\sysext\core\Tests\Unit\Cache\Backend\FileBackendTest.php:127
D:\Version Control\Git\TYPO3\TYPO3.CMS\master\vendor\phpunit\phpunit\phpunit:47

Associated revisions

Revision 1a9e1f29 (diff)
Added by Nicole Cordes over 4 years ago

[BUGFIX] Failing Unit Tests on Windows systems

Due to realpath usage some Unit Tests are failing on Windows systems.
The tests have to ensure that forward slashes are used for comparison.

Resolves: #73006
Releases: master, 7.6, 6.2
Change-Id: Iee64ab873d519fee07c6b69e63de1f7d645c071b
Reviewed-on: https://review.typo3.org/46340
Reviewed-by: Wouter Wolters <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Helmut Hummel <>
Reviewed-by: Markus Sommer <>
Reviewed-by: Daniel Maier <>
Tested-by: Daniel Maier <>
Reviewed-by: Oliver Klee <>
Tested-by: Wouter Wolters <>

Revision 2b1d3064 (diff)
Added by Nicole Cordes over 4 years ago

[BUGFIX] Failing Unit Tests on Windows systems

Due to realpath usage some Unit Tests are failing on Windows systems.
The tests have to ensure that forward slashes are used for comparison.

Resolves: #73006
Releases: master, 7.6, 6.2
Change-Id: Iee64ab873d519fee07c6b69e63de1f7d645c071b
Reviewed-on: https://review.typo3.org/46602
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision 413430bf (diff)
Added by Nicole Cordes over 4 years ago

[BUGFIX] Failing Unit Tests on Windows systems

Due to realpath usage some Unit Tests are failing on Windows systems.
The tests have to ensure that forward slashes are used for comparison.

Resolves: #73006
Releases: master, 7.6, 6.2
Change-Id: Iee64ab873d519fee07c6b69e63de1f7d645c071b
Reviewed-on: https://review.typo3.org/46603
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Morton Jonuschat <>
Tested-by: Morton Jonuschat <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46340

#2 Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46602

#3 Updated by Nicole Cordes over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Gerrit Code Review over 4 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46603

#5 Updated by Nicole Cordes over 4 years ago

  • Status changed from Under Review to Resolved

#6 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF