Bug #73631

search section names omit first character (TYPO3 6.2 only)

Added by Daniel Neugebauer over 5 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2016-02-23
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When using search sections, indexed_search (in TYPO3 6.2) assumes it will generate a path which has always been prepended by a leading slash and always removes the first character. I can't tell why but that's not the case for one of our websites thus omitting the first character of the section's name.

Patches for TYPO3 7 or master are not required as the fix for #23156 appears to have solved that issue for later releases.

A patch for TYPO3 6.2 will be pushed for review in a few minutes. It replaces the substr(..., 1) call by preg_replace('#^/#', '', ...) to remove only one leading slash if present. However, I wasn't able to figure out when SearchController.php will be accessed so I could only test the change for SearchFormController.php. I'm confident the patch will work on the other controller but since it hasn't been tested I'm just tagging this issue 70% complete.


Related issues

Related to TYPO3 Core - Feature #23156: Slash is hard–coded in the page pathClosed2010-07-12

Actions
#1

Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46846

#2

Updated by Anonymous over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 70 to 100
#3

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF