Bug #74127

Ensure compatibility of t3d export files

Added by Nicole Cordes over 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2016-03-04
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Currently it is not possible to import t3d files into TYPO3 which were exported with 7.6 or master. Due to an error in extension dependency setting, the import fails with message "DEPENDENCY: The extension with key "" must be installed!"

Associated revisions

Revision 1ebadc6d (diff)
Added by Nicole Cordes over 4 years ago

[BUGFIX] Ensure t3d compatibility for supported TYPO3 version

This patch fixes an issue with unclean t3d export due to string to array
conversion. This is important to be able to import a t3d files which was
exported with 7.6 and above even in 6.2. This is needed as we do not
have any chance to see which TYPO3 version was used for the export.

Resolves: #74127
Releases: master, 7.6, 6.2
Change-Id: I6ba7b825241c2ca439c485aaf597b019b7ac8997
Reviewed-on: https://review.typo3.org/47032
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Eugen Lang <>
Tested-by: Christian Kuhn <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

Revision 9db88b5e (diff)
Added by Nicole Cordes over 4 years ago

[BUGFIX] Ensure t3d compatibility for supported TYPO3 version

This patch fixes an issue with unclean t3d export due to string to array
conversion. This is important to be able to import a t3d files which was
exported with 7.6 and above even in 6.2. This is needed as we do not
have any chance to see which TYPO3 version was used for the export.

Resolves: #74127
Releases: master, 7.6, 6.2
Change-Id: I6ba7b825241c2ca439c485aaf597b019b7ac8997
Reviewed-on: https://review.typo3.org/47091
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

Revision ee7fafde (diff)
Added by Nicole Cordes over 4 years ago

[BUGFIX] Ensure t3d compatibility for supported TYPO3 version

This patch fixes an issue with unclean t3d export due to string to array
conversion. This is important to be able to import a t3d files which was
exported with 7.6 and above even in 6.2. This is needed as we do not
have any chance to see which TYPO3 version was used for the export.

Resolves: #74127
Releases: master, 7.6, 6.2
Change-Id: I6ba7b825241c2ca439c485aaf597b019b7ac8997
Reviewed-on: https://review.typo3.org/47090
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Daniel Goerz <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47032

#2 Updated by Nicole Cordes over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Gerrit Code Review over 4 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47090

#4 Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47091

#5 Updated by Nicole Cordes over 4 years ago

  • Status changed from Under Review to Resolved

#6 Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF