Bug #75194

the folder vendor is not exist

Added by Xiaoling Peng over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
composer
Target version:
-
Start date:
2016-03-20
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
vendor
Complexity:
Is Regression:
No
Sprint Focus:

Description

Fatal error: require(): Failed opening required '/var/www/html/t3dev/TYPO3.CMS/typo3/../vendor/autoload.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/html/t3dev/TYPO3.CMS/typo3/index.php on line 19

Auswahl_048.png View (68 KB) Xiaoling Peng, 2016-03-20 14:46

History

#1 Updated by Wouter Wolters over 3 years ago

  • Status changed from New to Needs Feedback
  • Assignee deleted (Markus Sommer)
  • Target version deleted (7.6.5)

How did you installed TYPO3?

Did you already tried composer install ?

#2 Updated by Xiaoling Peng over 3 years ago

I just changed the symlink typo3_src in my TYPO3 7.6.4 system. like typo3_src -> ../t3dev/TYPO3.CMS

#3 Updated by Wouter Wolters over 3 years ago

That looks like a git clone you have there. You need to execute composer install to get the vendor dir or download the source from https://get.typo3.org

#4 Updated by Xiaoling Peng over 3 years ago

I got the Core from hier: https://git.typo3.org/Packages/TYPO3.CMS
git clone --recursive git://git.typo3.org/Packages/TYPO3.CMS.git TYPO3.CMS

#5 Updated by Wouter Wolters over 3 years ago

  • Status changed from Needs Feedback to Closed

Please read https://github.com/TYPO3/TYPO3.CMS/blob/master/INSTALL.md carefully! This is not an issue in the TYPO3 core and I therefor close the ticket. If you need more support please join us on Slack (https://github.com/TYPO3/TYPO3.CMS#chat-with-us).

Also available in: Atom PDF