Bug #75464

Wrong call of namespaces in Filelist-Search

Added by Gianluigi Martino over 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Category:
-
Target version:
-
Start date:
2016-04-08
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Because the call of namespaces is wrong, icons and context menu doesnt'works


Related issues

Duplicated by TYPO3 Core - Feature #75458: Show cut/copy button in filelist after search Closed 2016-04-08

Associated revisions

Revision 060186b7 (diff)
Added by Benni Mack over 4 years ago

[BUGFIX] User proper Fluid namespace detection

The Fluid namespaces can be put in short-syntax, and in tags to be
resolved. However, if the template source is very large, then
preg_match_all() stops and returns "0" although the matched values are
within $matches. However, the $matched result is "0".

The regular expression for doing so, is very exhaustive and greedy, and
uses preg_match_all() however, preg_match() does the job as well.

Additionally, the regular expression is changed to be less
greedy (using *?).

An example where this is necessary is the FileList search module where
the additional namespaces are not resolved currently and the core icons
are not shown, because of the memory - exhausting regular expression.

Change-Id: Ia685091fe9fbcbb1520415ee5d48925852d1a400
Resolves: #75464
Releases: master
Reviewed-on: https://review.typo3.org/47549
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>
Reviewed-by: Daniel Goerz <>
Tested-by: Daniel Goerz <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47549

#2 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47549

#3 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47549

#4 Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47549

#5 Updated by Gerrit Code Review over 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47549

#6 Updated by Gerrit Code Review over 4 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47549

#7 Updated by Gerrit Code Review over 4 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47549

#8 Updated by Gerrit Code Review over 4 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47549

#9 Updated by Benni Mack over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF