Bug #75484

Error in file list module when having a read-only filemount for the same path as a normal filemount

Added by Lorenz Ulrich almost 4 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2016-04-10
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Test case:

  • Assign a normal filemount, e.g. for 1:/test (Folder test in storage 1) to a user
  • Set a read-only filemount for the root path of storage 1: options.folderTree.altElementBrowserMountPoints = 1:/

This is the case in an environment where editors only can manipulate certain folders (e.g. of their departments), but should be able to read/use all file of the website.

Now, after switching to a non-admin user that has both filemounts assigned, a click to "test" in the File List module leads to an "endless" call that is terminated at max_execution_time.

This problem was introduced with https://review.typo3.org/#/c/39898 in #67245. Before (or without) that change, this setup works/worked fine.


Related issues

Related to TYPO3 Core - Bug #67245: Prevent information disclosure in file list Closed 2015-06-02
Duplicates TYPO3 Core - Bug #73735: Error 500 (mem exhausted) when a user has multiple filemounts Closed 2016-02-29

History

#1 Updated by Lorenz Ulrich almost 4 years ago

The exact change causing it is:

EXT:core/Classes/Resource/Folder.php:

$rootId = $this->storage->getRootLevelFolder(FALSE)->getIdentifier();

to

$rootId = $this->storage->getRootLevelFolder()->getIdentifier();

--> $respectFileMounts flag in ResourceStorage::getRootLevelFolder set to TRUE

#2 Updated by Frans Saris almost 4 years ago

ok, could also reproduce it with only filemount records:

- create a readonly filemount to 1:/
- create a filemount to 1:/user_uploads/

make sure the 1:/ has a lower uid then 1:/user_uploads

add the 2 filemounts to the user and visit fileadmin as that user

#3 Updated by Frans Saris almost 4 years ago

  • Status changed from New to Rejected

Duplicate of #73735

Also available in: Atom PDF