Bug #75744

BUG with flux:wizard.link linkValidator js in Typo3 7.6.5

Added by Bharat parmar almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2016-04-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I have created custom fluid content Element in TYPO3 7.6.5 i used below code for it

<flux:field.input name="url" label="Link">
<flux:wizard.link activeTab="page" />
</flux:field.input>

but in backend it show popup(alert box) with text "The fields marked with an exclamation mark are not yet correctly filled in. Please complete them properly." while saving data in backend form of my custom fluid content element.

The same is working well with typo3 7.6.4 but now its not working.


Files

Auswahl_691.png (1.5 KB) Auswahl_691.png Empty link field Daniel Schultheis, 2016-04-20 17:37
Auswahl_692.png (2.37 KB) Auswahl_692.png Link field with page id (Validation fails) Daniel Schultheis, 2016-04-20 17:37
Auswahl_693.png (2.57 KB) Auswahl_693.png Link field with page id and target (Validation OK) Daniel Schultheis, 2016-04-20 17:37
#1

Updated by Bharat parmar almost 6 years ago

Bharat parmar wrote:

I have created custom fluid content Element in TYPO3 7.6.5 i used below code for it

>                 <flux:field.input name="url" label="Link">
>              <flux:wizard.link activeTab="page" />
>         </flux:field.input>

but in backend it show popup(alert box) with text "The fields marked with an exclamation mark are not yet correctly filled in. Please complete them properly." while saving data in backend form of my custom fluid content element.

The same is working well with typo3 7.6.4 but now its not working.

#2

Updated by Wouter Wolters almost 6 years ago

  • Assignee deleted (TYPO3 Release Team)
  • Target version deleted (7.6.5)
#3

Updated by Nicole Cordes over 5 years ago

  • Status changed from New to Needs Feedback

Hi Bharat,

I don't get the relation between your fluid (frontend output?) and the backend (TCA -> record form?). Can you describe your problem a bit more in detail please?

#4

Updated by Daniel Schultheis over 5 years ago

In my opinion it looks like link validation fails since TYPO3 7.6.5 if a page id is provided in a link textfield. If you provide any additional data in the link field (like the target attribute) validation succeeds.

I have attached some screenshots to show you what exactly I mean.

#5

Updated by Bharat parmar over 5 years ago

Hi Daniel,

Thanks for your reply it was clear from your screenshot that since TYPO3 7.6.5 linkvalidator is not consistence but the validation rule are same for typo3 backend provided link field(ex. tt_content Header link) link field and my "flux:wizard.link" generated link field but one is working correct and other one is not.
Is there are some extra configuration to be done to adapt new TYPO3 7.6.5 Changes or its a core bug which may be resolve in next LTS release?

#6

Updated by Daniel Schultheis over 5 years ago

Ok, it looks like this issue is totally flux related. If you are still experiencing this issue, you should have a look at https://github.com/FluidTYPO3/flux/issues/1116 where the devs have submitted a patch which fixes this issue in flux.

Therefore I think the bug report here can be closed.

#7

Updated by Bharat parmar over 5 years ago

Thanks you Daniel :)

#8

Updated by Wouter Wolters over 5 years ago

  • Status changed from Needs Feedback to Closed

Closed as requested. Bug in Flux it seems.

Also available in: Atom PDF