Bug #75864

Extension installation fails if extension needs dependencies to be installed

Added by Nicole Cordes over 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2016-04-22
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Due to the refactoring of the package manager the Extension Manager fails to install extension with dependencies. You can test that behavior by installing the extension "introduction" which depends on "bootstrap_package".

Associated revisions

Revision 9302d22c (diff)
Added by Nicole Cordes over 4 years ago

[BUGFIX] Prevent resetting of Package Manager packages

Due to Package Manager cleanup in https://review.typo3.org/46389/
the packageStatesConfiguration property only includes active packages.

This patch prevents resetting the packages property which should store
all available package objects to the active ones.

Resolves: #75864
Releases: master
Change-Id: I44d4e074a04cc294cacf9ec9a707b2367b57a2bb
Reviewed-on: https://review.typo3.org/47852
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Andreas Fernandez <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47852

#2 Updated by Nicole Cordes over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF