Project

General

Profile

Actions

Bug #76929

closed

FlexForm displayCond not working

Added by Willi Martens almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2016-07-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
#tce #flexforms #displayCond
Complexity:
Is Regression:
No
Sprint Focus:

Description

displayCondition in FlexForm of pi_flexform-field of table tt_content ´┐╝has no effect

ext_tables.php

  \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addPiFlexFormValue(
    '*',
    'FILE:EXT:my_ext/Configuration/FlexForms/textmedia.xml',
    'textmedia'
  );

textmedia.xml


  <displayCond>
    <numIndex index="0">FIELD:imageorient:=:100</numIndex>
  </displayCond>


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #77135: <config> of flexform gets rendered allthough <displayCond> is NOT fulfilledClosed2016-07-17

Actions
Is duplicate of TYPO3 Core - Bug #75646: displaycond not working WITHIN flexform sectionsClosed2016-04-15

Actions
Actions #1

Updated by Willi Martens almost 8 years ago

also no effect

  <displayCond>FIELD:layout:=:1</displayCond>

Actions #2

Updated by Willi Martens almost 8 years ago

see https://forge.typo3.org/issues/33390

<displayCond>FIELD:parentRec.layout:=:1</displayCond>

this works but why is it not documented? https://docs.typo3.org/typo3cms/TCAReference/Reference/Columns/Flex/Index.html

Actions #3

Updated by Georg Ringer over 7 years ago

  • Status changed from New to Closed

closing because duplicate of #75646

Actions

Also available in: Atom PDF