Bug #76983

SectionIndex menu - no translated elements without parent in default language

Added by Alexander Vogt over 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2016-07-07
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

A TMENU with enabled sectionIndex only displays records with parent in default language. Translated content elements without parent are not visible.

It should be possible to add the option "includeRecordsWithoutDefaultTranslation" in sectionindex menu (sysext/frontend/Classes/ContentObject/Menu/AbstractMenuContentObject->sectionIndex - Line 2125 $selectSetup).

History

#1 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from New to Needs Feedback

Is this issue still present? I tried the following test with 87.15:

Prerequisites

1) Fresh TYPO3 8.7.15 installation with two languages: default (italian) and id=1 (english)
2) Create a page TEST and translate it in english

Execution

1) Create a simple sectionindex menu like this:

page.3 = HMENU
page.3.entryLevel=-1
page.3{
 1=TMENU
 1.wrap = <ul>|</ul>
 1.NO = 1
 1.NO.wrapItemAndSub = <li>|</li>
 1.sectionIndex = 1 
 1.sectionIndex.type = header 
}

2) on the page "TEST", set the display mode to languages
2.1) on the english variant, create a content element, type headline and give it an headline "TEST HEADLINE"
3) preview page

Results:

the sectionindex menu is visible, and with the link to the element:

<ul><li><a href="index.php?id=38&amp;L=1#c146">TEST HEADLINE</a></li></ul>

Is this test sufficient? Please, if I have misunderstood something, add a step-by-step guide about how to reproduce your issue. Thank you!

#2 Updated by Riccardo De Contardi about 1 year ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

Also available in: Atom PDF