Bug #77516

verifyFilenameAgainstDenyPattern not UTF-8 save

Added by Tim Spiekerkötter about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-08-16
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I found a problem in verifyFilenameAgainstDenyPattern while using Helmut's upload_example extension.

When a user tries to upload a file named "Zdjęcie 10.jpg", the method verifyFilenameAgainstDenyPattern returns FALSE even though there are no control characters within the filename. The preg_match call in the method is missing the "u" modifier.

Am I missing something or are there any reasons for this behaviour?

This happens only on the live server (Mittwald PHP 5.6.10), and I can't reproduce this behaviour on my local dev system.


Related issues

Duplicates TYPO3 Core - Bug #67061: Upload of files with "Umlaute" is not possible for non-admins when utf8 filesystem is enabled Closed 2015-05-20

History

#1 Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49495

#2 Updated by Mathias Brodala almost 3 years ago

  • Status changed from Under Review to Closed

Please continue in #67061.

Also available in: Atom PDF