Bug #77753

TYPO3 Translation User rights

Added by daniel no-lastname-given about 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend User Interface
Target version:
Start date:
2016-09-01
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
On Location Sprint

Description

Hi,
I have TYPO3 7.6 installed. I have 2 languages installed. German(default) and Chinese.
I setted up a chinese user.
The user rights for the chinese user should be like this:
- the chinese user can only edit chinese contents
- the chinese user can make new records and stuff on the chinese language.

And there is the problem, i cannot say that the chinese user can only make new records in chinese language. The chinese user can always make new records in default language. I can lock the edit functionality for the default language for the chinese user but i can not lock the creation of new content elements for the default language for the chinese user.
Is this normal behaviour of TYPO3 or not?

Thank you.

Associated revisions

Revision cecdee2d (diff)
Added by Daniel Maier about 3 years ago

[BUGFIX] Show Create Content button only for allowed languages

The Create Content button inside the Page Module is now only shown for
languages the backend-user is actually allowed to edit. That way, users
that are restricted to a specific language and not allowed to edit the
default language, do not see this button inside the default language column
any more. (Note: this patch only hides the button itself, the later processing
was already prevented before.)

Resolves: #77753
Releases: master, 7.6
Change-Id: I44ebacaf1d1d0635b0af1e7e52689f077f6fa2b4
Reviewed-on: https://review.typo3.org/49800
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Jigal van Hemert <>
Tested-by: Jigal van Hemert <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

Revision 218ea578 (diff)
Added by Daniel Maier almost 3 years ago

[BUGFIX] Show Create Content button only for allowed languages

The Create Content button inside the Page Module is now only shown for
languages the backend-user is actually allowed to edit. That way, users
that are restricted to a specific language and not allowed to edit the
default language, do not see this button inside the default language column
any more. (Note: this patch only hides the button itself, the later processing
was already prevented before.)

Resolves: #77753
Releases: master, 7.6
Change-Id: I44ebacaf1d1d0635b0af1e7e52689f077f6fa2b4
Reviewed-on: https://review.typo3.org/49847
Tested-by: TYPO3com <>
Reviewed-by: Michael Oehlhof <>
Reviewed-by: Daniel Maier <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Daniel Maier about 3 years ago

  • Status changed from New to Accepted
  • Target version set to 8.4
  • Sprint Focus set to On Location Sprint

#2 Updated by Daniel Maier about 3 years ago

daniel no-lastname-given wrote:

Hi,
I have TYPO3 7.6 installed. I have 2 languages installed. German(default) and Chinese.
I setted up a chinese user.
The user rights for the chinese user should be like this:
- the chinese user can only edit chinese contents
- the chinese user can make new records and stuff on the chinese language.

And there is the problem, i cannot say that the chinese user can only make new records in chinese language. The chinese user can always make new records in default language. I can lock the edit functionality for the default language for the chinese user but i can not lock the creation of new content elements for the default language for the chinese user.
Is this normal behaviour of TYPO3 or not?

Thank you.

After a first look, I would say that it seems to be an issue of the Page-Module, which shows the "Add content" button even when the user is not allowed to create records in default language. The later handling of record-creation seems to be correct, allowing only the languages the user is restricted to, but not default.

#3 Updated by Daniel Maier about 3 years ago

  • Category set to Backend User Interface

#4 Updated by Daniel Maier about 3 years ago

  • Assignee set to Daniel Maier

#5 Updated by Gerrit Code Review about 3 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49800

#6 Updated by Gerrit Code Review about 3 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49847

#7 Updated by Daniel Maier about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF