Feature #77939

EXT:form - allow sender (in addition to from)

Added by Christian Hernmarck about 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2016-09-13
Due date:
% Done:

0%

Estimated time:
1.00 h
PHP Version:
Tags:
Complexity:
easy
Sprint Focus:

Description

A year ago I asked for the ReplyTo field... now it's another one: the "sender" field.

The reason is almost the same (not the mail adress given in the form as mail sender) with a little difference: a customer wants to have the mail address from the form in the mail client "from" column... (which is not the case with replyTo.

So I ask for the support of another field which is (technically) a step forward for TYPO3 mailform:

Possibility to configure a "Sender" (not the "from") - because the author of a mail does only press "submit" on the form but does not send the mail with his mail client - so technically the website owner or webhoster does send the mail which can be written in the mail so it also passes SPF without problems.

wikipedia:
Sender: Address of the actual sender acting on behalf of the author listed in the From: field (secretary, list manager, etc.).

It's allowed to have more than one from (author) - but only one sender.

Since "senderEmail" and "senderName" is already used in tx_form we need another expression - a renaming (fromEmail,fromName or authorEmail, authorName) seems not to be an option (even if the technical expressions are different).

Maybe techsendEmail and techsendName (or realsender...) - inputs are welcome.

There is already a setSender in the Swiftmailer library. so the function to implement is almost the same as setFrom but IMHO without the Field option... (you don't want the "sender" to be dynamic...). I can send the patch, when the variable name is found....

#1

Updated by Bjoern Jacob about 5 years ago

  • Tracker changed from Bug to Feature
  • Status changed from New to Needs Feedback
  • Assignee set to Christian Hernmarck

Sorry, this is not a bug. Definitely not :) TYPO3 6.2 does only receive priority patches. If you want, you can check the new form integration for TYPO3 v8, see #77910. With this new version it is very easy to implement new fields (even in the form editor). Try it out and see how it could be implemented for master. Thanks!

#2

Updated by Bjoern Jacob almost 5 years ago

Christian, since a few weeks the new version of form is merged and part of 8.5. Did you already try it out?

#3

Updated by Bjoern Jacob almost 5 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Christian Hernmarck)

Closing this issue. Did not get any further reponsonse. If the settings of the new finishers are not good enough please open a new issue.

Also available in: Atom PDF