Bug #78096

\TYPO3\CMS\Backend\View\PageLayoutView::getResult is incompatible to DatabaseConnection usage

Added by Nicole Cordes over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2016-09-28
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Having an extension which is not migrated to Doctrine currently, it is impossible to use the function \TYPO3\CMS\Backend\View\PageLayoutView::getResult as it expects a Doctrine statement object.

As this public function executes some internal (protected) logic it should be compatible with both, Doctrine and mysqli_result objects.

Associated revisions

Revision 215abe05 (diff)
Added by Nicole Cordes over 3 years ago

[BUGFIX] Deprecate support mysqli_result in PageLayoutView::getResult

Due to change https://review.typo3.org/48240/ the method only supports
Doctrine Statement objects. An extension which uses the DatabaseConnection
is not able to use this function anymore. This patch re-adds the support
for mysqli_result objects and throws a deprecaction message as information.

Resolves: #78096
Releases: master
Change-Id: I921fccb9132af2426627d8918c782323878c373d
Reviewed-on: https://review.typo3.org/50052
Tested-by: TYPO3com <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Markus Sommer <>
Tested-by: Markus Sommer <>
Reviewed-by: Morton Jonuschat <>
Tested-by: Morton Jonuschat <>

History

#1 Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50052

#2 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50052

#3 Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50052

#4 Updated by Nicole Cordes over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF