Bug #79088

Record title in "Move element" must be escaped

Added by Gianluigi Martino almost 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2016-12-23
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

See image attached.
The title in clickmenu move element shows html because it is not escaped

escape-pidRecordTitle.png View (16.2 KB) Gianluigi Martino, 2016-12-23 17:18

Associated revisions

Revision 6e73c8c0 (diff)
Added by Gianluigi Martino over 3 years ago

[TASK] Disable escaping pidRecordTitle in clickmenu move element

Prevent the escaping of pidRecordTitle in click menu move element. The
escaping is already done in the MoveElementController due to the usage
of the third (prep) parameter in BackendUtility::getRecordTitle.

Resolves: #79088
Releases: master
Change-Id: Ib35e9d5a3da7fc76085db910927ada17dbdd0b06
Reviewed-on: https://review.typo3.org/51041
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>
Reviewed-by: Mathias Schreiber <>
Tested-by: Mathias Schreiber <>
Tested-by: TYPO3com <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

History

#1 Updated by Gerrit Code Review almost 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51041

#2 Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51041

#3 Updated by Gerrit Code Review almost 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51041

#4 Updated by Gianluigi Martino over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF