Bug #79681

Configured Fluid template not found

Added by Nicole Cordes almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Fluid
Target version:
Start date:
2017-02-08
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Given a module configuration like

module.tx_example {
    view {
        templateRootPaths.0 = EXT:example/Resources/Private/Backend/Templates/
        partialRootPaths.0 = EXT:example/Resources/Private/Backend/Partials/
        layoutRootPaths.0 = EXT:example/Resources/Private/Backend/Layouts/
    }
}

I expect the backend module using a template in Resources/Private/Backend/Templates/ but instead only Resources/Private/Templates/ is taken into account for finding the module view template.

This is related to patch https://review.typo3.org/51283/ where the default template paths are always overwriting the configured ones.


Related issues

Related to TYPO3 Core - Bug #81099: Extension cannot override default (fallback) templateRootPaths/partialRootPaths/partialRootPaths New 2017-05-01

Associated revisions

Revision cdd6dca4 (diff)
Added by Nicole Cordes almost 3 years ago

[BUGFIX] Avoid overwriting configured Fluid template paths

Due to change https://review.typo3.org/51283/ the defaultPaths in
Fluid overwrite the configuration paths for the first (0-indexed)
array item. This means currently it is not possible to define an
own Fluid template path with index 0. This patch merges both arrays
and ensures the configuration paths are added at last. This is needed
because Fluid Standalone is using template paths from last to first.

Resolves: #79681
Releases: master
Change-Id: I84398c8218836b46583333bf64ba87ef4a55625d
Reviewed-on: https://review.typo3.org/51575
Tested-by: TYPO3com <>
Reviewed-by: Claus Due <>
Reviewed-by: Thomas Hohn <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Josef Glatz <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

History

#1 Updated by Gerrit Code Review almost 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51575

#2 Updated by Nicole Cordes almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Christoph Bessei over 2 years ago

  • Related to Bug #81099: Extension cannot override default (fallback) templateRootPaths/partialRootPaths/partialRootPaths added

#4 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF