Bug #79757

Backend login not possible

Added by Nicole Cordes over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
-
Target version:
Start date:
2017-02-11
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Due to the new session handling it is not possible to login into the backend with a valid user. A database error is thrown because the field ses_anonymous is not available

Associated revisions

Revision c500f4f6 (diff)
Added by Nicole Cordes over 3 years ago

[BUGFIX] Only set a session anonymous if in FE context

The session id regeneration must not touch the sys_anonymous field
of the session record, since it only exists for FE session.
The FrontendUserAuthentication is responsible for this.

Resolves: #79757
Releases: master
Change-Id: Iefcc678b9171830b587432fa7fbbc9e77033931f
Reviewed-on: https://review.typo3.org/51635
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51635

#2 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51635

#3 Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51635

#4 Updated by Nicole Cordes over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF