Bug #79759

Failing unit tests on Windows system in TYPO3\CMS\Install\Tests\Unit\UpgradeAnalysis\DocumentationFileTest

Added by Nicole Cordes almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
-
Target version:
Start date:
2017-02-11
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Due to wrong path handling in \TYPO3\CMS\Install\UpgradeAnalysis\DocumentationFile several unit tests fail on Windows systems because of the usage of DIRECTORY_SEPARATOR constant.

TYPO3\CMS\Install\Tests\Unit\UpgradeAnalysis\DocumentationFileTest::findDocumentationFilesReturnsArrayOfFiles
InvalidArgumentException: the given file does not belong to the changelog dir. Aborting

D:\Version Control\Git\TYPO3\TYPO3.CMS\master\typo3\sysext\install\Classes\UpgradeAnalysis\DocumentationFile.php:95
D:\Version Control\Git\TYPO3\TYPO3.CMS\master\typo3\sysext\install\Classes\UpgradeAnalysis\DocumentationFile.php:236
D:\Version Control\Git\TYPO3\TYPO3.CMS\master\typo3\sysext\install\Classes\UpgradeAnalysis\DocumentationFile.php:79
D:\Version Control\Git\TYPO3\TYPO3.CMS\master\typo3\sysext\install\tests\Unit\UpgradeAnalysis\DocumentationFileTest.php:145

TYPO3\CMS\Install\Tests\Unit\UpgradeAnalysis\DocumentationFileTest::extractingTagsProvidesTagsAsDesired
InvalidArgumentException: the given file does not belong to the changelog dir. Aborting

D:\Version Control\Git\TYPO3\TYPO3.CMS\master\typo3\sysext\install\Classes\UpgradeAnalysis\DocumentationFile.php:95
D:\Version Control\Git\TYPO3\TYPO3.CMS\master\typo3\sysext\install\Classes\UpgradeAnalysis\DocumentationFile.php:236
D:\Version Control\Git\TYPO3\TYPO3.CMS\master\typo3\sysext\install\Classes\UpgradeAnalysis\DocumentationFile.php:79
D:\Version Control\Git\TYPO3\TYPO3.CMS\master\typo3\sysext\install\tests\Unit\UpgradeAnalysis\DocumentationFileTest.php:158

TYPO3\CMS\Install\Tests\Unit\UpgradeAnalysis\DocumentationFileTest::filesAreFilteredByUsersChoice
InvalidArgumentException: the given file does not belong to the changelog dir. Aborting

Associated revisions

Revision cd1f5284 (diff)
Added by Nicole Cordes almost 3 years ago

[BUGFIX] Fix wrong path handling in DocumentationFile

Currently several unit tests are failing on Windows system due to the
usage of DIRECTORY_SEPARATOR. This patch ensures unix-like paths are
used everywhere and tests are running again.

Resolves: #79759
Releases: master
Change-Id: I60d8e2c31b56fae627c59b8aa4e8fed0eb85b0a9
Reviewed-on: https://review.typo3.org/51637
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Reviewed-by: Thomas Hohn <>
Reviewed-by: Jasmina Ließmann Tested-by: Jasmina Ließmann <code@frauliessmann.de> Reviewed-by: Christian Matthes Tested-by: Christian Matthes Reviewed-by: Markus Klein <markus.klein@typo3.org> Tested-by: Markus Klein <markus.klein@typo3.org>

History

#1 Updated by Gerrit Code Review almost 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51637

#2 Updated by Nicole Cordes almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF