Project

General

Profile

Actions

Bug #80115

closed

Install Tool: DB connect fails after entering credentials if wrong database is configured

Added by Andreas Wolf over 7 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
Category:
Install Tool
Target version:
Start date:
2017-03-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Situation

  • LocalConfiguration.php contains (incomplete) database credentials: some missing information (e.g. password) and there is no database with the configured name
  • Install Tool is invoked and asks for DB credentials
  • no matter what credentials are entered, an error is shown; basically, the user is deadlocked at that point w/o manual intervention in the config file

Observed behaviour

  • after entering (correct) credentials, an error "Database connect not successful – Connecting to the database with given settings failed. Please check." is shown

Expected behaviour

  • Proceeding to the next step where the database can be chosen or created

How to reproduce

  • Take an existing, configured installation
  • Open LocalConfiguration.php, delete the "password" entry of the default DB connection there and change the database name to something that does not exist
  • Open the install tool. It should ask for database credentials.
Actions #1

Updated by Andreas Wolf over 7 years ago

  • Subject changed from Install Tool: Connect fails after entering credentials if wrong database is configured to Install Tool: DB connect fails after entering credentials if wrong database is configured
Actions #2

Updated by Andreas Wolf over 7 years ago

  • Description updated (diff)
Actions #3

Updated by Thomas Hohn over 7 years ago

Could you provide some more information on how you end up with a broken LocalConfiguration.php?
Is it created during some automatic setup process and then you manually perform an Initial installation on the site?

Actions #4

Updated by Thomas Hohn over 7 years ago

  • Assignee set to Thomas Hohn
Actions #5

Updated by Thomas Hohn over 7 years ago

One of the "problems" is that the installation is not considered as an initial installation since it's more an upgrade instead of an initial installation

Actions #6

Updated by Thomas Hohn about 7 years ago

Won't do.

Actions #7

Updated by Thomas Hohn about 7 years ago

  • Status changed from New to Rejected
Actions

Also available in: Atom PDF