Bug #80145

Link hander to record throws exception with ck_editor

Added by Fernando Arconada over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2017-03-05
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

ck_editor throws an exception with a custom linkhandler

Argument 1 passed to TYPO3\CMS\Core\Configuration\Richtext::getConfiguration() must be of the type string, array given, called in /var/www/vhosts/vendor/typo3/cms/typo3/sysext/rte_ckeditor/Classes/Controller/BrowseLinksController.php on line 150

It's very easy to reproduce, details on the screenshots attached

Captura de pantalla 2017-03-05 a las 15.31.14.png View (26.2 KB) Fernando Arconada, 2017-03-05 15:36

Captura de pantalla 2017-03-05 a las 15.32.58.png View (147 KB) Fernando Arconada, 2017-03-05 15:36

Captura de pantalla 2017-03-05 a las 15.33.45.png View (25.2 KB) Fernando Arconada, 2017-03-05 15:36

History

#1 Updated by Georg Ringer over 2 years ago

  • Status changed from New to Needs Feedback
  • Sprint Focus set to Stabilization Sprint
    TCEMAIN.linkHandler.anIdentifier {
        handler = TYPO3\CMS\Recordlist\LinkHandler\RecordLinkHandler
        label = LLL:EXT:extension/Resources/Private/Language/locallang.xlf:link.customTab
        configuration {
            table = tx_news_domain_model_news
            storagePid = 82
            hidePageTree = 1
        }
        scanBefore = page
    }

this is the config as tet.

I can't reproduce it in current master as there changed quite few things, can you please retest there?

#2 Updated by Fernando Arconada over 2 years ago

TYPO3 8.6.1 -> Exception
TYPO3 8.7-Dev -> works

This version works
Updating typo3/cms (8.6.1 => dev-master 3094854) Checking out 3094854db1

Will this fix be in 8.6.2, isn't it?

#3 Updated by Georg Ringer over 2 years ago

  • Status changed from Needs Feedback to Closed

Thanks for the feedback. As it is solved I am closing this issue.

Also available in: Atom PDF