Bug #80184

FSC "shortcut" / "insert record" renders headline but should not

Added by Sascha Egerer over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Fluid Styled Content
Target version:
-
Start date:
2017-03-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

The content element "shortcut"/"insert record" has a header field in the backend with a note that this header is not rendered in the frontend. But in FSC it is rendered.


Related issues

Is duplicate of TYPO3 Core - Bug #79825: Name of reference (Insert records) shows up in frontendClosedBenni Mack2017-02-15

Actions
#1

Updated by Sascha Egerer over 4 years ago

  • Assignee deleted (Benni Mack)
#2

Updated by Sascha Egerer over 4 years ago

  • Assignee set to Sascha Egerer

One fix could be to remove the "Default" Layout from the template. But this does also mean that wrappers with the content element id are not rendered. But i think they should not be renderd anyway because if you have visual gutters in the layout file they will be rendered twice (once for the "insert record" element and once for the referenced element).

So i would suggest to remove the layout and just render the referenced content element. Any opinions?

#3

Updated by Sascha Egerer over 4 years ago

#4

Updated by Sascha Egerer over 4 years ago

  • Status changed from New to Closed

Also available in: Atom PDF