Bug #80209

Wrong variable checked in getTitleField

Added by Christer V over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2017-03-09
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In BrowseLinksController::getTitleField the wrong variable is checked, which can cause an PHP warning since $title can become null instead of the empty string '';


$title = !$this->classesAnchorDefault[$this->displayedLinkHandlerId] ? '' : $this->classesAnchorDefaultTitle[$this->displayedLinkHandlerId];

to


$title = !$this->classesAnchorDefaultTitle[$this->displayedLinkHandlerId] ? '' : $this->classesAnchorDefaultTitle[$this->displayedLinkHandlerId];

Associated revisions

Revision b79c6794 (diff)
Added by Christer V over 2 years ago

[BUGFIX] Wrong variable checked in BrowseLinksController

Changed so the correct variable classesAnchorDefaultTitle is checked.

In BrowseLinksController::getTitleField the wrong variable was checked,
which could cause faulty behaviour and an PHP warning since $title could
become null instead of the empty string.

Resolves: #80209
Releases: master
Change-Id: Ie2c82085438d0f0303d0d61ccb0a095ee37da338
Reviewed-on: https://review.typo3.org/51991
Tested-by: TYPO3com <>
Reviewed-by: Thomas Hohn <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision b38a219f (diff)
Added by Christer V over 2 years ago

[BUGFIX] Check correct variable in BrowseLinksController

Make sure to check the correct variable classesAnchorDefaultTitle
when fetching the title of anchors.

This affects CKeditor as well as htmlarea.

Resolves: #80209
Releases: master, 7.6
Change-Id: I1cdd760ee1fe2879ac53edff38f25515d656d706
Reviewed-on: https://review.typo3.org/52205
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

Revision 687f8995 (diff)
Added by Christer V over 2 years ago

[BUGFIX] Check correct variable in BrowseLinksController

Make sure to check the correct variable classesAnchorDefaultTitle
when fetching the title of anchors.

This affects CKeditor as well as htmlarea.

Resolves: #80209
Releases: master, 7.6
Change-Id: I1cdd760ee1fe2879ac53edff38f25515d656d706
Reviewed-on: https://review.typo3.org/52215
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Tested-by: TYPO3com <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51991

#2 Updated by Christer V over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Gerrit Code Review over 2 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52205

#4 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52205

#5 Updated by Gerrit Code Review over 2 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52215

#6 Updated by Christer V over 2 years ago

  • Status changed from Under Review to Resolved

#7 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF