Project

General

Profile

Actions

Bug #80220

closed

http_code not returned for HEAD requests in \TYPO3\CMS\Core\Utility\GeneralUtility::getUrl

Added by Nicole Cordes almost 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2017-03-10
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If you switch to a HEAD request in \TYPO3\CMS\Core\Utility\GeneralUtility::getUrl and provide a report array to get more information, the header status will not be return. This happens because the content from that request (obviously) is emtpy and considerer as an error.

Actions #1

Updated by Gerrit Code Review almost 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51994

Actions #2

Updated by Gerrit Code Review almost 7 years ago

Patch set 2 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51994

Actions #3

Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51994

Actions #4

Updated by Nicole Cordes over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #5

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF