Bug #80326

Link class from RTE gets lost

Added by Dirk Weber almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2017-03-17
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Though it is correctly saved the lib.parseFunc_RTE.tags.a.typolink gets rid of my custom set class.

I use a quite easy setup with fsc in Typo3 V8.6. I can add classes (used both htmlarea and ckeditor) and use them in frontend. But link classes get stripped in the frontend. While it remains visible in the backend editor, it does not survive rendering to frontend.

The problem is located somewhere in here:
lib.parseFunc_RTE.tags.a

Let me know if I can clarify things. I maintain a ton of typo3 pages and this hasn't been a problem since v8

History

#1 Updated by Andrii Valkiv almost 3 years ago

The issue meets because of typolink configuration. TypoScript for <a> tag is wrong. Instead of

lib.parseFunc_RTE.tags.a.typolink.aTagParams.data = parameters:allParams

it must be

lib.parseFunc_RTE.tags.a.typolink.ATagParams.data = parameters:allParams

So aTagParams is not correctly written. It must be ATagParams. Just change it in your TypoScript for temporary solution and it'll work like a charm. But of course it should be fixed fluid_styled_content extension.

#2 Updated by Harald Krischner almost 3 years ago

Andrii Valkiv wrote:

So aTagParams is not correctly written. It must be ATagParams. Just change it in your TypoScript for temporary solution and it'll work like a charm. But of course it should be fixed fluid_styled_content extension.

Thanks for your help, your temp solution works fine.

#3 Updated by Andre Koller almost 3 years ago

Fixed in dev-master

#4 Updated by Riccardo De Contardi almost 3 years ago

  • Status changed from New to Closed

thank you for testing. I close it.

Also available in: Atom PDF