Bug #80374

Streamline frontend login to be compatible with css styled content and fluid styled content

Added by Benjamin Kott over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Content Rendering
Target version:
Start date:
2017-03-21
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

The content element "Login" currently has several issues especially with fluid styled content.

- Login is configured to work best with css styled content
- Wrapping frames are completly missing, even fields are available
- Base configuration is loaded by ext_typoscript_setup and highly depends on the configuration of the static template, this makes it hard to override or make adjustments
- Configuration is in most cases only possible with adjusting the typoscript setup because constants are not existing

#1

Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52110

#2

Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52110

#3

Updated by Gerrit Code Review over 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52110

#4

Updated by Gerrit Code Review over 4 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52110

#5

Updated by Anonymous over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF