Bug #80436

Linkhandler record browsing not working with CKEditor

Added by Mathias Brodala over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2017-03-24
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Apparently the linkhandler record browsing introduced with #79626 is not working with CKEditor.

Internally CKEditor always passes tt_content as table in BrowseLinksController::getUrlParameters which in turn prevents record listing due to a check in AbstractDatabaseRecordList::generateList() which disallows tables aside from $this->table filled from $_GET['table'].


Related issues

Duplicates TYPO3 Core - Bug #79645: RteCKEditor BrowseLinksController doesn't follow the LinkBrowser/Linkhandler API Closed 2017-02-06

History

#1 Updated by Mathias Brodala over 2 years ago

  • Status changed from New to Closed

This was fixed with #79645 in master.

Also available in: Atom PDF