Bug #80675

Recycler Scheduler job fails - due to missing doctrine bind variables

Added by Christer V over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Recycler
Target version:
Start date:
2017-04-04
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Recycler Scheduler job fails due to missing doctrine bind variables.

To reproduce:
  • Setup Recycler Scheduler job
  • Select the "Backend Layout" table
  • Run

Error:

Execution of task "Remove deleted records (recycler)" failed with the following message: An exception occurred while executing 'SELECT `icon` FROM `backend_layout` WHERE (`deleted` = :dcValue1) AND (`tstamp` < :dcValue2)': You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ':dcValue1) AND (`tstamp` < :dcValue2)' at line 1

This seems to be caused by CleanerTask->deleteFilesForTable which reuses the $constraints from CleanerTask->cleanTable, but without the doctrine createNamedParameter bind variables.

Associated revisions

Revision 9819cad4 (diff)
Added by Christer V over 2 years ago

[BUGFIX] Do not use doctrine constraints without bind values

Changed so doctrine constraints without the corresponding
bind values aren't passed around.

The $constraints variable defined in CleanerTask->cleanTable
is reused in CleanerTask->deleteFilesForTable, but without
the doctrine createNamedParameter bind variables, since the
querybuilder is recreated. This caused the task to fail.

Resolves: #80675
Releases: master
Change-Id: I2da9b33f884f51bf9d90a9d08841fb4491eedea2
Reviewed-on: https://review.typo3.org/52362
Tested-by: TYPO3com <>
Reviewed-by: Thomas Hohn <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Thomas Hohn over 2 years ago

  • Subject changed from Recycler Scheduler job fails do to missing doctrine bind variables to Recycler Scheduler job fails - due to missing doctrine bind variables
  • Description updated (diff)

#2 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52362

#3 Updated by Christer V over 2 years ago

To reproduce
  • Setup the "Remove deleted records" task
  • Select "Backend Layout" as table
  • Run

#4 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52362

#5 Updated by Christer V over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF