Bug #81470

prevent exception in ImageCropUpdater

Added by Nicole Cordes over 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2017-06-05
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Given:

An installation with deleted sys_file_records pointing to a deleted file in sys_file

Expectation:

The ImageCropUpdater should be update without an error.

Actual:

An exception is thrown because of missing sys_file information.
`Argument 1 passed to TYPO3\CMS\Core\Imaging\ImageManipulation\Area::makeRelativeBasedOnFile() must implement interface TYPO3\CMS\Core\Resource\FileInterface, null given, called in typo3\sysext\install\Classes\Updates\RowUpdater\ImageCropUpdater.php on line 85`

Associated revisions

Revision 30139ac4 (diff)
Added by Nicole Cordes over 2 years ago

[BUGFIX] Prevent exception in ImageCropUpdater

The ImageCropUpdater throws an exception if a non-existing file is tried
to be processed. This happens because deleted rows are updated. The patch
checks the returned file object before further processing is executed.

Resolves: #81470
Releases: master, 8.7
Change-Id: I488994b1ad842e28d928f3b4a2db1c8c007afe3c
Reviewed-on: https://review.typo3.org/53120
Tested-by: TYPO3com <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision a25e353a (diff)
Added by Nicole Cordes over 2 years ago

[BUGFIX] Prevent exception in ImageCropUpdater

The ImageCropUpdater throws an exception if a non-existing file is tried
to be processed. This happens because deleted rows are updated. The patch
checks the returned file object before further processing is executed.

Resolves: #81470
Releases: master, 8.7
Change-Id: I488994b1ad842e28d928f3b4a2db1c8c007afe3c
Reviewed-on: https://review.typo3.org/53123
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53120

#2 Updated by Gerrit Code Review over 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53123

#3 Updated by Nicole Cordes over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Gerrit Code Review over 2 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53123

#5 Updated by Nicole Cordes over 2 years ago

  • Status changed from Under Review to Resolved

#6 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF