Bug #81609

Display Messages checkbox missing from Admin Panel

Added by Torsten Schrade 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-06-19
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The admin panel normally has a checkbox to show log messages set with function \TYPO3\CMS\Core\TimeTracker\TimeTracker->setTSlogMessage. Since TYPO3 version 8.7 this checkbox seems to have been accidentally skipped during the refactoring of class \TYPO3\CMS\Frontend\View\AdminPanelView->getTSDebugModule.

This makes it impossible to show TS log messages in the admin panel in TYPO3 versions 8.7 and above. Currently the only way to display TS log messages is to generally activate them with TSConfig (admPanel.tsdebug.displayMessages = 1). TYPO3 7.6 still has the checkbox.

The functionality is still there. The HTML for the checkbox just needs to be added in function getTSDebugModule (see screenshots before/after) and according patch.

AdminPanel_before.png View (56.7 KB) Torsten Schrade, 2017-06-19 06:34

AdminPanel_after.png View (64.6 KB) Torsten Schrade, 2017-06-19 06:34

Associated revisions

Revision a91ec116 (diff)
Added by Torsten Schrade about 1 month ago

[BUGFIX] Add missing "Display messages" checkbox to admin panel

The checkbox for displaying TypoScript log messages is missing from
the admin panel since TYPO3 version 8.7 and above. This change adds
the missing checkbox again.

Resolves: #81609
Releases: master, 8.7
Change-Id: I830a2b78ba6ef001ed524dd6d5f41f2acb2a27b1
Reviewed-on: https://review.typo3.org/53259
Tested-by: TYPO3com <>
Reviewed-by: Joerg Boesche <>
Reviewed-by: Jan Stockfisch <>
Reviewed-by: Jasmina Ließmann Tested-by: Jasmina Ließmann <code@frauliessmann.de> Reviewed-by: Richard Haeser <richard@maxserv.com> Tested-by: Richard Haeser <richard@maxserv.com> Reviewed-by: Wouter Wolters <typo3@wouterwolters.nl> Tested-by: Wouter Wolters <typo3@wouterwolters.nl>

Revision 5bff6f46 (diff)
Added by Torsten Schrade about 1 month ago

[BUGFIX] Add missing "Display messages" checkbox to admin panel

The checkbox for displaying TypoScript log messages is missing from
the admin panel since TYPO3 version 8.7 and above. This change adds
the missing checkbox again.

Resolves: #81609
Releases: master, 8.7
Change-Id: I830a2b78ba6ef001ed524dd6d5f41f2acb2a27b1
Reviewed-on: https://review.typo3.org/53462
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Gerrit Code Review 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53259

#2 Updated by Gerrit Code Review about 1 month ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53462

#3 Updated by Torsten Schrade about 1 month ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF