Bug #81811

Publishing FAL metadata throws TypeError in TYPO3\CMS\Version\Hook\DataHandlerHook::version_swap

Added by Michael Gaier about 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2017-07-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The following Exception is thrown, if you try to publish FAL metadata.

Core: Exception handler (WEB): Uncaught TYPO3 Exception: 
Argument 3 passed to TYPO3\CMS\Version\Hook\DataHandlerHook::version_swap_processFields() must be of the type array, null given,
called in /var/www/typo3_src-master/typo3/sysext/version/Classes/Hook/DataHandlerHook.php on line 885
TypeError thrown in file /var/www/typo3_src-master/typo3/sysext/version/Classes/Hook/DataHandlerHook.php in line 1071. Requested URL:
http://v8.typo3.local/typo3/index.php?ajaxID=%2Fajax%2Fworkspace%2Fdispatch&ajaxToken=7f1a50f75b23d2ba5ddac20d4dcdcaa15ea74df6

The TCA definition for the "width" and "height" colums is missing a 'config'-section.

'width' => [
'l10n_mode' => 'exclude'
],
'height' => [
'l10n_mode' => 'exclude'
]

Files

tca-sys_file_metadata-missing_config_entry.patch (851 Bytes) tca-sys_file_metadata-missing_config_entry.patch adds config entry Michael Gaier, 2017-07-06 12:37
#1

Updated by Michael Gaier about 4 years ago

Duplicate of #73076 and #77619

#2

Updated by Riccardo De Contardi almost 3 years ago

  • Status changed from New to Closed

As both issues #73076 and #77619 has been resolved (since Nov. 2017) I think it is safe to close this one, too.

If you think that this is the wrong decision or experience the issue again on recent TYPO3 versions like 8.7 or 9.5, please reopen it or open a new issue with a reference to this one.

Thank you and sorry for this late answer.

Also available in: Atom PDF