Bug #81824

Wizards add not working with MM

Added by XIMA MEDIA GmbH over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
DataHandler aka TCEmain
Target version:
-
Start date:
2017-07-10
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello guys,

maybe you can fix this buggy wizard ;)

State:
  1. Table "A" is in relation with table "B" via a MM-table.
  2. TCA is configured to list the relation as a side-by-side field:
    'config'  => [
        'type'          => 'select',
        'renderType'    => 'selectMultipleSideBySide',
        'foreign_table' => 'tx_myextname_domain_model_b',
        'MM'            => 'tx_myextname_a_col_mm',
        'size'          => 10,
        'autoSizeMax'   => 30,
        'maxitems'      => 9999,
        'multiple'      => 0,
        'wizards'       => [
            '_PADDING'  => 1,
            '_VERTICAL' => 1,
            'add'       => [
                'module' => [
                    'name' => 'wizard_add',
                ],
                'type'   => 'script',
                'title'  => 'Create new',
                'icon'   => 'EXT:backend/Resources/Public/Images/FormFieldWizard/wizard_add.gif',
                'params' => [
                    'table'    => 'tx_myextname_domain_model_b',
                    'pid'      => '###CURRENT_PID###',
                    'setValue' => 'prepend'
                ]
            ]
        ]
    ]
    

Expected behaviour:
When clicking on "add"-icon and saving a newly generated item of B, then it should prepended to the list of related items.

Actual behaviour:
All related items are going to be deleted except one and the newly generated item.

Thanks 4 help!
Greetings :)


Related issues

Is duplicate of TYPO3 Core - Bug #76863: MM Relation with selectMultipleSideBySide Field - Add wizard resets the MM RelationClosedThomas Hohn2016-06-29

Actions
Has duplicate TYPO3 Core - Bug #82016: Wizards add still not working with MMClosed2017-08-01

Actions
#1

Updated by Kevin Ditscheid over 3 years ago

  • Is duplicate of Bug #76863: MM Relation with selectMultipleSideBySide Field - Add wizard resets the MM Relation added
#2

Updated by Georg Ringer over 3 years ago

  • Status changed from New to Closed

as this is a duplicate, a close this issue.

#3

Updated by XIMA MEDIA GmbH over 3 years ago

  • Has duplicate Bug #82016: Wizards add still not working with MM added

Also available in: Atom PDF