Bug #82475

Workspace : notification mail are not send if changeable preselection is disable

Added by shinsei san about 2 years ago. Updated 5 months ago.

Status:
Resolved
Priority:
Must have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2017-09-13
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Test in typo3 8.7.6

Case : you use workspace notification and Default notification mail recipients
If you disable "changeable preselection" no mail are send to all selected "Default notification mail recipienrs", but mail are send to other users who are manualy selected by the user when stage change.

But if you enable ""changeable preselection" mail are send correctly to all users

Associated revisions

Revision 71acb536 (diff)
Added by Hannes Bochmann 5 months ago

[BUGFIX] Consider default recipients in preselection check

When checking if a workspace stage has a preselection the
default recipients need to be considered, too.
Consequently the default recipients field in the TCA needs
to stay visible if the option to show the notification dialog
is unchecked.

Resolves: #82475
Releases: master, 9.5, 8.7
Change-Id: I7edb257c803a519a06e8fc65fe2b5cb03d3ce7ff
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61056
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Benni Mack <>
Reviewed-by: Frank Naegler <>
Reviewed-by: Anja Leichsenring <>

Revision 522b0731 (diff)
Added by Hannes Bochmann 5 months ago

[BUGFIX] Consider default recipients in preselection check

When checking if a workspace stage has a preselection the
default recipients need to be considered, too.
Consequently the default recipients field in the TCA needs
to stay visible if the option to show the notification dialog
is unchecked.

Resolves: #82475
Releases: master, 9.5, 8.7
Change-Id: I7edb257c803a519a06e8fc65fe2b5cb03d3ce7ff
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61055
Tested-by: TYPO3com <>
Tested-by: Daniel Windloff
Tested-by: Andreas Fernandez <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Daniel Windloff
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Anja Leichsenring <>

Revision b50f7f8b (diff)
Added by Hannes Bochmann 5 months ago

[BUGFIX] Consider default recipients in preselection check

When checking if a workspace stage has a preselection the
default recipients need to be considered, too.
Consequently the default recipients field in the TCA needs
to stay visible if the option to show the notification dialog
is unchecked.

Resolves: #82475
Releases: master, 9.5, 8.7
Change-Id: I7edb257c803a519a06e8fc65fe2b5cb03d3ce7ff
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61001
Tested-by: TYPO3com <>
Tested-by: Anja Leichsenring <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Anja Leichsenring <>
Reviewed-by: Andreas Fernandez <>

History

#1 Updated by DMK E-BUSINESS GmbH 6 months ago

We experience the same bug. The Bug seems to exist in TYPO3 9.5, too. It would be great if it would be fixed.

Furthermore the label for the button "show dialog" seems to be misleading. I would expect that this checkbox controls only whether the dialog is shown or not. But it also controls whether mails are sent at all (@see \TYPO3\CMS\Workspaces\Controller\Remote\ActionHandler::getSentToStageWindow()). I would expect that the default notification mail recipients are still editable if the checkbox is not checked and mails are sent to those default recipients. Otherwise there is no way to define fixed recipients that can't be changed at all or am I missing something?. I mean that the selected default recipients can't be unchecked and more recipients can't be checked/defined either.

#2 Updated by Gerrit Code Review 6 months ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61001

#3 Updated by Gerrit Code Review 6 months ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61032

#4 Updated by Gerrit Code Review 6 months ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61001

#5 Updated by Gerrit Code Review 6 months ago

Patch set 3 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61001

#6 Updated by Gerrit Code Review 6 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61055

#7 Updated by Gerrit Code Review 6 months ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61056

#8 Updated by Gerrit Code Review 6 months ago

Patch set 4 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61001

#9 Updated by Anonymous 5 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF